
Charts
A simple chart in Excel can say more than a sheet full of numbers. As you'll see, creating charts is very
easy.

Create a Chart

To create a line chart, execute the following steps.

1. Select the range A1:D7.

2. On the Insert tab, in the Charts group, click the Line symbol.

3. Click Line with Markers.



Result:

Note: enter a title by clicking on Chart Title. For example, Wildlife Population.

Change Chart Type

You can easily change to a different type of chart at any time.

1. Select the chart.

2. On the Design tab, in the Type group, click Change Chart Type.



3. On the left side, click Column.

4. Click OK.

Result:



Switch Row/Column

If you want to display the animals (instead of the months) on the horizontal axis, execute the following 
steps.

1. Select the chart.

2. On the Design tab, in the Data group, click Switch Row/Column.

Result:



Legend Position

To move the legend to the right side of the chart, execute the following steps.

1. Select the chart.

2. Click the + button on the right side of the chart, click the arrow next to Legend and click Right.

Result:

Data Labels

You can use data labels to focus your readers' attention on a single data series or data point.

1. Select the chart.

2. Click a green bar to select the Jun data series.



3. Hold down CTRL and use your arrow keys to select the population of Dolphins in June (tiny green 
bar).

4. Click the + button on the right side of the chart and click the check box next to Data Labels.

Result:



Column Chart

Column charts are used to compare values across categories by using vertical bars.

To create a column chart, execute the following steps.

1. Select the range A1:A7, hold down CTRL, and select the range C1:D7.

2. On the Insert tab, in the Charts group, click the Column symbol.

3. Click Clustered Column.



Result:

Note: only if you have numeric labels, empty cell A1 before you create the column chart. By doing this,
Excel does not recognize the numbers in column A as a  data series and automatically places these
numbers on the horizontal (category) axis. After creating the chart, you can enter the text Year into cell
A1 if you like.



Line Chart
Line charts are used to display trends over time. Use a line chart if you have text labels, dates or a few
numeric labels on the horizontal axis. Use a scatter plot (XY chart) to show scientific XY data.

To create a line chart, execute the following steps.

1. Select the range A1:D7.

2. On the Insert tab, in the Charts group, click the Line symbol.

3. Click Line with Markers.



Result:

Note: only if you have numeric labels, empty cell A1 before you create the line chart. By doing this,
Excel does not recognize the numbers in column A as a  data series and automatically places these
numbers on the horizontal (category) axis. After creating the chart, you can enter the text Year into cell
A1 if you like.

Let's customize this line chart.

To change the data range included in the chart, execute the following steps.



4. Select the line chart.

5. On the Design tab, in the Data group, click Select Data.

6. Uncheck Dolphins and Whales and click OK.

Result:

To change the color of the line and the markers, execute the following steps.



7. Right click the line and click Format Data Series.

The Format Data Series pane appears.

8. Click the paint bucket icon and change the line color.

9. Click Marker and change the fill color and border color of the markers.

Result:



To add a trendline, execute the following steps.

10. Select the line chart.

11. Click the + button on the right side of the chart, click the arrow next to Trendline and then click 
More Options.

The Format Trendline pane appears.

12. Choose a Trend/Regression type. Click Linear.

13. Specify the number of periods to include in the forecast. Type 2 in the Forward box.



Result:



To change the axis type to Date axis, execute the following steps.

14. Right click the horizontal axis, and then click Format Axis.

The Format Axis pane appears.

15. Click Date axis.



Result:



Bar Chart
A bar chart is the horizontal version of a column chart. Use a bar chart if you have large text labels.

To create a bar chart, execute the following steps.

1. Select the range A1:B6.

2. On the Insert tab, in the Charts group, click the Column symbol.

3. Click Clustered Bar.

Result:





Area Chart
An area chart is a line chart with the areas below the lines filled with colors. Use a stacked area chart
to display the contribution of each value to a total over time.

To create an area chart, execute the following steps.

1. Select the range A1:D7.

2. On the Insert tab, in the Charts group, click the Line symbol.

3. Click Area.



Result. In this example, some areas overlap.

Below you can find the corresponding line chart to clearly see this.



4. Change the chart's subtype to Stacked Area (the one next to Area).

Result:

Note: only if you have numeric labels, empty cell A1 before you create the area chart. By doing this,
Excel does not recognize the numbers in column A as a  data series and automatically places these
numbers on the horizontal (category) axis. After creating the chart, you can enter the text Year into cell
A1 if you like.



Scatter Plot
Use a scatter plot (XY chart) to show scientific XY data. Scatter plots are often used to find out if
there's a relationship between variable X and Y.

Only Markers

To find out if there is a relationship between X (a person's salary) and Y (his/her car price), execute the
following steps.

1. Select the range A1:B10.

2. On the Insert tab, in the Charts group, click the Scatter symbol.

3. Click Scatter.



Result:

Note: we added a trendline to clearly see the relationship between these two variables.

Straight Lines

To create a scatter plot with straight lines, execute the following steps.

1. Select the range A1:D22.



2. On the Insert tab, in the Charts group, click the Scatter symbol.

3. Click Scatter with Straight Lines.



Note: also see the subtype Scatter with Smooth Lines.

Result:

Note: we added a horizontal and vertical axis title. The horizontal axis of a scatter plot is a value axis,
so you have more axis scaling options (the same as a vertical axis which always is a value axis).



Data Series
A row or column of numbers that are plotted in a chart is called a data series. You can plot one or more
data series in a chart.

To create a column chart, execute the following steps.

1. Select the range A1:D7.

2. On the Insert tab, in the Charts group, click the Column symbol.

3. Click Clustered Column.



Result:

Select Data Source

To launch the Select Data Source dialog box, execute the following steps.

1. Select the chart. Right click, and then click Select Data.



The Select Data Source dialog box appears.

2. You can find the three data series (Bears, Dolphins and Whales) on the left and the horizontal axis 
labels (Jan, Feb, Mar, Apr, May and Jun) on the right.

Switch Row/Column

If you click Switch Row/Column, you'll have 6 data series (Jan, Feb, Mar, Apr, May and Jun) and three 
horizontal axis labels (Bears, Dolphins and Whales).



Result:

Add, Edit, Remove and Move

You can use the Select Data Source dialog box to add, edit, remove and move data series, but there's a
quicker way.

1. Select the chart.

2. Simply change the range on the sheet.

Result:





Chart Sheet

So far we have only seen charts on the same worksheet as the source data (embedded charts). However,
you can also move a chart to a separate sheet that only contains a chart (chart sheet).

To move a chart to a chart sheet, execute the following steps.

1. Select the chart.

2. On the Design tab, in the Location group, click Move Chart.

The Move Chart dialog box appears.

3. Click New sheet and enter a name.

4. Click OK.

Result:



Note: repeat these steps, but instead of New sheet at step 3, click Object in, to move the chart back to
the same worksheet as the source data.



Trendline

This example teaches you how to add a trendline to a chart in Excel.

1. Select the chart.

2. Click the + button on the right side of the chart, click the arrow next to Trendline and then click 
More Options.

The Format Trendline pane appears.

3. Choose a Trend/Regression type. Click Linear.

4. Specify the number of periods to include in the forecast. Type 3 in the Forward box.

5. Check "Display Equation on chart" and "Display R-squared value on chart".



Result:



Explanation: Excel uses the method of least squares to find a line that best fits the points. The R-
squared value equals 0.9295, which is a good fit. The closer to 1, the better the line fits the data. The
trendline predicts 120 sold Wonka bars in period 13. You can verify this by using the equation. y =
7.7515 * 13 + 18.267 = 119.0365.

6.  Instead  of  using  this  equation,  you  can  use  the  FORECAST.LINEAR function  in  Excel.  This
function predicts the same future values.

7. The FORECAST.ETS function in Excel predicts a future value using Exponential Triple Smoothing,
which takes into account seasonality.





Error Bars

This example teaches you how to add error bars to a chart in Excel.

1. Select the chart.

2. Click the + button on the right side of the chart, click the arrow next to Error Bars and then click
More Options.

Notice the shortcuts to quickly display error bars using the Standard Error, a percentage value of 5% or
1 standard deviation.

The Format Error Bars pane appears.

3. Choose a Direction. Click Both.

4. Choose an End Style. Click Cap.

5. Click Fixed value and enter the value 10.



Result:



Note: if you add error bars to a  scatter plot, Excel also adds horizontal error bars. In this example,
these error bars have been removed. The vertical error bar in period 1 predicts 10 to 30 sold Wonka
bars, the vertical error bar in period 2 predicts 22 to 42 sold Wonka bars, etc.



Sparklines

Sparklines in Excel are graphs that fit in one cell. Sparklines are great for displaying trends.

Insert Sparklines

To insert sparklines, execute the following steps.

1. Select the cells where you want the sparklines to appear. In this example, we select the range G2:G4.

2. On the Insert tab, in the Sparklines group, click Line.

3. Click in the Data Range box and select the range B2:F4.

4. Click OK.

Result:



5. Change the value in cell F2 to 1186.

Result. Excel automatically updates the sparkline.

Customize Sparklines

To customize sparklines, execute the following steps.

1. Select the sparklines.

2. On the Design tab, in the Show group, check High Point and Low point.

Result:

Note: to make the sparklines larger, simply change the row height and column width of the sparkline 
cells.

3. On the Design tab, in the Style group, choose a nice visual style.



Result:

Note: the high points are colored green now and the low points are colored red.

To delete a sparkline, execute the following steps.

4. Select 1 or more sparklines.

5. On the Design tab, in the Group group, click Clear.

Compare Sparklines

By default, each sparkline has its own vertical scale. The maximum value is plotted at the top of the
cell. The minimum value is plotted at the bottom of the cell.

To compare sparklines, execute the following steps.

1. Select the sparklines.

2. On the Design tab, in the Type group, click Column.

Result:



Note: all green bars have the same height, but the maximum values (B2, E3 and F4) are different!

3. Select the sparklines.

4. On the Design tab, in the Group group, click Axis.

5. Under Vertical Axis Minimum Value Options and Vertical Axis Maximum Value Options, select 
Same for All Sparklines.

Result:



Note: now you can clearly see that the earnings of Jack are much higher.

Win/Loss Sparklines

A win/loss sparkline only shows whether each value is positive (win) or negative (loss). Sometimes this
can be useful.

Note: try it yourself. Download the Excel file and select the sparklines. Next, on the Design tab, click
Column (instead of Win/Loss) to clearly see how high and low the values are.



Combination Chart

A combination chart is a chart that combines two or more chart types in a single chart.

To create a combination chart, execute the following steps.

1. Select the range A1:C13.

2. On the Insert tab, in the Charts group, click the Combo symbol.

3. Click Create Custom Combo Chart.

The Insert Chart dialog box appears.

4. For the Rainy Days series, choose Clustered Column as the chart type.

5. For the Profit series, choose Line as the chart type.

6. Plot the Profit series on the secondary axis.



7. Click OK.

Result:





Gauge Chart
A gauge chart (or speedometer chart) combines a Doughnut chart and a Pie chart in a single chart. I

This is what the spreadsheet looks like.

To create a gauge chart, execute the following steps.

1. Select the range H2:I6.

Note: the Donut series has 4 data points and the Pie series has 3 data points.

2. On the Insert tab, in the Charts group, click the Combo symbol.

3. Click Create Custom Combo Chart.

The Insert Chart dialog box appears.

4. For the Donut series, choose Doughnut (fourth option under Pie) as the chart type.

5. For the Pie series, choose Pie as the chart type.

6. Plot the Pie series on the secondary axis.



7. Click OK.

8. Remove the chart title and the legend.

9. Select the chart. On the Format tab, in the Current Selection group, select the Pie series.

10. On the Format tab, in the Current Selection group, click Format Selection and change the angle of
the first slice to 270 degrees.



11. Hold down CTRL and use the ← and → keys to select a single data point. On the Format tab, in the
Shape Styles group, change the Shape Fill of each point. Point 1 = No Fill, point 2 = black and point 3
= No Fill.

Result:

Explanation: the Pie chart is nothing more than a transparent slice of 75 points, a black slice of 1 point
(the needle) and a transparent slice of 124 points.

12. Repeat steps 9 to 11 for the Donut series. Point 1 = red, point 2 = yellow, point 3 = green and point
4 = No Fill.

Result:

13. Select the chart. On the Format tab, in the Current Selection group, select the Chart Area. In the
Shape Styles group, change the Shape Fill to No fill and the Shape Outline to No Outline.



14. Use the Spin Button to change the value in cell I3 from 75 to 76. The Pie chart changes to a
transparent slice of 76 points, a black slice of 1 point (the needle), and a transparent slice of 200 - 1 - 76
= 123 points. The formula in cell I5 ensures that the 3 slices sum up to 200 points.



Thermometer Chart

This example teaches you how to create a  thermometer chart in  Excel. A thermometer chart shows
you how much of a goal has been achieved.

To create a thermometer chart, execute the following steps.

1. Select cell B16.

Note: adjacent cells should be empty.

2. On the Insert tab, in the Charts group, click the Column symbol.

3. Click Clustered Column.



Result:

Further customize the chart.

4. Remove the chart tile and the horizontal axis.

5. Right click the blue bar, click Format Data Series and change the Gap Width to 0%.



6. Change the width of the chart.

7.  Right  click  the  percentages  on the  chart,  click  Format  Axis,  fix  the  minimum bound to  0,  the
maximum bound to 1 and set the Major tick mark type to Outside.



Result:





Gantt Chart

Excel does not offer Gantt as chart type, but it's  easy to create a  Gantt chart by customizing the
stacked bar chart type. Below you can find our Gantt chart data.

To create a Gantt chart, execute the following steps.

1. Select the range A3:C11.

2. On the Insert tab, in the Charts group, click the Column symbol.

3. Click Stacked Bar.



Result:

4. Enter a title by clicking on Chart Title. For example, Build a House.

5. Click the legend at the bottom and press Delete.

6. The tasks (Foundation, Walls, etc.) are in reverse order. Right click the tasks on the chart,  click
Format Axis and check 'Categories in reverse order'.



Result:

7. Right click the blue bars, click Format Data Series, Fill & Line icon, Fill, No fill.



8. Dates and times are stored as numbers in Excel and count the number of days since January 0, 1900.
1-jun-2017 (start) is the same as 42887. 15-jul-2017 (end) is the same as 42931. Right click the dates
on the chart, click Format Axis and fix the minimum bound to 42887, maximum bound to 42931 and
Major unit to 7.

Result. A Gantt chart in Excel.



Note that the plumbing and electrical work can be executed simultaneously.



Pareto Chart

This example teaches you how to create a Pareto chart in Excel. The Pareto principle states that, for
many events, roughly 80% of the effects come from 20% of the causes. In this example, we will see
that roughly 80% of the complaints come from 20% of the complaint types.

Excel 2016 or later

To create a Pareto chart in Excel 2016 or later, execute the following steps.

1. Select the range A3:B13.

2. On the Insert tab, in the Charts group, click the Histogram symbol.

3. Click Pareto.



Result:

Note: a Pareto chart combines a column chart and a line graph.

4. Enter a chart title.

5. Click the + button on the right side of the chart and click the check box next to Data Labels.

Result:



Conclusion: the orange Pareto line shows that (789 + 621) / 1722 ≈ 80% of the complaints come from 2
out of 10 = 20% of the complaint types (Overpriced and Small portions). In other words: the Pareto
principle applies.

All Versions

If you don't have Excel 2016 or later, simply create a Pareto chart by combining a column chart and a
line graph. This method works with all versions of Excel.

1. First, select a number in column B.

2. Next, sort your data in descending order. On the Data tab, in the Sort & Filter group, click ZA.



3. Calculate the cumulative count. Enter the formula shown below into cell C5 and drag the formula
down.

4. Calculate the cumulative %. Enter the formula shown below into cell D4 and drag the formula down.



Note: cell C13 contains the total number of complaints. When we drag this formula down, the absolute
reference ($C$13) stays the same, while the relative reference (C4) changes to C5, C6, C7, etc.

5. Select the data in column A, B and D. To achieve this, hold down CTRL and select each range.

6. On the Insert tab, in the Charts group, click the Column symbol.



7. Click Clustered Column.

8. Right click on the orange bars (Cumulative %) and click Change Series Chart Type...



The Change Chart Type dialog box appears.

9. For the Cumulative % series, choose Line with Markers as the chart type.

10. Plot the Cumulative % series on the secondary axis.

11. Click OK.



Note: Excel 2010 does not offer combo chart as one of the built-in chart types. If you're using Excel
2010, instead of executing steps 8-10, simply select Line with Markers and click OK. Next, right click
on the orange/red line and click Format Data Series. Select Secondary Axis and click Close.

12. Right click the percentages on the chart, click Format Axis and set the Maximum to 100.



Result:

Conclusion: the Pareto chart shows that 80% of the complaints come from 20% of the complaint types
(Overpriced and Small portions). In other words: the Pareto principle applies.
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