Conditional Formatting

Conditional formatting in Excel enables you to highlight cells with a certain color, depending on the
cell's value.

Highlight Cells Rules

To highlight cells that are greater than a value, execute the following steps.
1. Select the range A1:A10.
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2. On the Home tab, in the Styles group, click Conditional Formatting.
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3. Click Highlight Cells Rules, Greater Than.
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4. Enter the value 80 and select a formatting style.
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5. Click OK.
Result. Excel highlights the cells that are greater than 80.
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6. Change the value of cell A1 to 81.

Result. Excel changes the format of cell A1 automatically.
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Note: you can also use this category (see step 3) to highlight cells that are less than a value, between
two values, equal to a value, cells that contain specific text, dates (today, last week, next month, etc.),
duplicates or unique values.

Clear Rules

To clear a conditional formatting rule, execute the following steps.

1. Select the range A1:A10.

A B

1 81
2 ]
3 9
4 43
5 2
] 95
7 5
8 11
8 86
10 5?.
11

2. On the Home tab, in the Styles group, click Conditional Formatting.
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3. Click Clear Rules, Clear Rules from Selected Cells.
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Top/Bottom Rules

To highlight cells that are above average, execute the following steps.
1. Select the range A1:A10.
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2. On the Home tab, in the Styles group, click Conditional Formatting.
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3. Click Top/Bottom Rules, Above Average.
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4. Select a formatting style.
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Cancel

5. Click OK.
Result. Excel calculates the average (42.5) and formats the cells that are above this average.
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Note: you can also use this category (see step 3) to highlight the top n items, the top n percent, the
bottom n items, the bottom n percent or cells that are below average.



Conditional Formatting with Formulas

Take your Excel skills to the next level and use a formula to determine which cells to format. Formulas
that apply conditional formatting must evaluate to TRUE or FALSE.

1. Select the range A1:E5.

A B C D E F
1 50 77 33 20 96
2 39 66 20 61 44
3 94 99 97 41 52
4 36 43 70 13 54
5 15 ] 28 28 15.
6

2. On the Home tab, in the Styles group, click Conditional Formatting.
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3. Click New Rule.
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4. Select 'Use a formula to determine which cells to format'.
5. Enter the formula =ISODD(A1)

6. Select a formatting style and click OK.
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Edit the Rule Description:
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Result. Excel highlights all odd numbers.

A~ B | C | D | E | F
1 | 90 77 33 20 96
2 | 59 66 20 61 44
3 | 94 99 97 11 52
4 36 43 70 13 54
5 15 6 28 28 15
6

Explanation: always write the formula for the upper-left cell in the selected range. Excel automatically
copies the formula to the other cells. Thus, cell A2 contains the formula =ISODD(A2), cell A3 contains
the formula =ISODD(A3), etc.

Here's another example.

7. Select the range A2:D7.

A B C D E
1 Last Name Sales Country Quarter
2 |Smith 516,753.00 UK Qtr 3
3 |lohnson | 514,808.00 UsSA Qtr 4
4 |williams | 510,644.00 UK Qtr 2
5 |Jones 51,390.00 USA Qtr 3
& |Brown 54,865.00 USA Qtr 4
7 |williams | $12,438.00 UK a1 |
8




8. Repeat steps 2-4 above.
9. Enter the formula =$C2="USA"

10. Select a formatting style and click OK.
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Edit the Rule Description:
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Result. Excel highlights all USA orders.

A | B | C | D | E
1 _Last Name Sales Country Quarter

2 _Sr‘ni‘th 516,753.00 UK Qtr 3

3 |Johnson  $14,808.00 USA Qtr 4

4 |williams  $10,644.00 UK Qtr 2

5 |Jones 51,390.00 USA Qtr 3

6 Brown 54,865.00 USA Qtr4

7 _'I."‘u"illiar‘nS 512,438.00 UK Qtrl

8

Explanation: we fixed the reference to column C by placing a $ symbol in front of the column letter
($C2). As a result, cell B2, C2 and cell D2 also contain the formula =$C2="USA", cell A3, B3, C3 and
D3 contain the formula =$C3="USA", etc.



Filter

Filter your Excel data if you only want to display records that meet certain criteria.
1. Click any single cell inside a data set.

2. On the Data tab, in the Sort & Filter group, click Filter.
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Arrows in the column headers appear.

A B C D E
1 |Last Nan ~ Sales * | Count ~ | Quart -
2 |Smith 516,753.00 UK Qtr 3
3 |Jc|hr15c|n _I 514,808.00 USA Qtr 4
4 |williams  $10,644.00 UK Qtr2
5 |lones 51,390.00 USA Qtr 3
& |Brown 54,865.00 USA Qtr4
7 (Williams  512,438.00 UK Qtrl
g |Johnson 59,339.00 UK Qtr 2
g |Smith 518,919.00 USA Qtr 3
10 [Jones 59,213.00 USA Qtr4
11 [Jones 57.433.00 UK Qtri
12 |Brown 53,255.00 USA Qtr 2
13 |Williams  514,867.00 USA Qtr 3
14 (Williams | 519,302.00 UK Qtr4a
15 |Smith 59,698.00 USA Qtrl

16

3. Click the arrow next to Country.

4. Click on Select All to clear all the check boxes, and click the check box next to USA.
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5. Click OK.
Result. Excel only displays the sales in the USA.

A B C D E

1 |Last Nan = Sales = | Count-T| Quart ~
3 |Johnson _I 514,808.00 USA Qtr4

5 |Jones 51,390.00 USA, Qtr 3

6 |Brown 54,865.00 USA Qtr4

9 :Smith 518,919.00 USA Qtr 3

10 |Jones 59,213.00 USA Qtr4
12 |Brown $3,255.00 USA  Qtr2
13 |Williams 514,867.00 USA Qtr 3
15 |Smith $9,698.00 USA  Qtrl
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6. Click the arrow next to Quarter.

7. Click on Select All to clear all the check boxes, and click the check box next to Qtr 4.
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8. Click OK.
Result. Excel only displays the sales in the USA in Qtr 4.

A B | C | D | E
1 |Last Nan = Sales = | Count -7 Quart-T

3 |Johnson _|$14,EDE.DD Usa Qtr4

6 |Brown 54, 865.00 USA Qtr 4
10 |Jones 59,213.00 USA Qtr4
16

9. To remove the filter, on the Data tab, in the Sort & Filter group, click Clear. To remove the filter and
the arrows, click Filter.
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Sort

You can sort your Excel data on one column or multiple columns. You can sort in ascending or
descending order.

One Column

To sort on one column, execute the following steps.

1. Click any cell in the column you want to sort.

A B = D E
1 |Last Mame Sales Country Quarter

g |Smith .I 516,753.00 UK ofr 3
3 |Johnson 514,808.00 USA Ctra

4 |Williams  510,644.00 UK Qtr 2
5 |lanes 51,390.00 USA Qtr 3
6 |Brown 54, 865.00 USA Qtr 4
7 |(Williams  512,438.00 UK Qtr 1
& |Johnson 59,339.00 UK Qtr 2
g |Smith 518,919.00 USA Qtr 3
10 |Jones 59,213.00 USA Qtr 4
11 |lones 57,433.00 UK Qtr 1
12 |Brown 53,255.00 USA Qtr 2
13 |Williams  514,867.00 USA Qtr 3
14 |williams  519,302.00 UK Qtr 4
15 |Smith 59,598.00 USA Qtr 1
16

2. To sort in ascending order, on the Data tab, in the Sort & Filter group, click AZ.
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Result:



A B C D E

1 .Last MName Sales Country Quarter
2 |Brown _I 54, 865.00 USA, Qtr 4
3 |Brown $3,255.00 USA  Qtr2
4 |Johnson | 514,808.00 USA Qtr 4
5 |lohnsaon 59,339.00 UK Qtr 2
6 |lones 51,390.00 USA, Qtr 3
7 |lones 59,213.00 USA Qtr4
& |lones 57,433.00 UK Qtr 1
9 [Smith 516,753.00 UK Qtr 3
10 |Smith 518,919.00 UsA Qtr 3
11 |Smith 59,698.00 USA Qtrl
12 |williams  510,644.00 UK Qtr 2
13 |Williams  512,438.00 UK Qtrl
14 |williams  $14,867.00 USA Qtr 3
15 |Williams  519,302.00 UK Qtrd
16

Note: to sort in descending order, click ZA.

Multiple Columns

To sort on multiple columns, execute the following steps.
1. On the Data tab, in the Sort & Filter group, click Sort.
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The Sort dialog box appears.

2. Select Last Name from the 'Sort by' drop-down list.
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OK | | Cancel
3. Click on Add Level.
4. Select Sales from the 'Then by' drop-down list.
Sort ? >
—|— Add Level < Delete Level I:El Copy Level | ~ Options... My data has headers
Column Sort On Order
Sort by |LastNamE | |Cell‘u‘alues | |Ath |
Then by | Cell Values [v] |Atoz [v]
Last Mame
Country L
Cuarter
oK | | Cancel
5. Click OK.

Result. Records are sorted by Last Name first and Sales second.




A B C D E

1 .Last MName Sales Country Quarter
2 |Brown _I 53,255.00 USA Qtr 2
3 [Brown $4,865.00 USA  Qir4
4 |Johnson 59,339.00 UK Qtr 2
5 |Johnson  $14,808.00 USA Qtr4
6 |Jones 51,390.00 USA, Qtr 3
7 |Jones 57.433.00 UK Qtri
8 |Jones 59,213.00 USA Qtr 4
9 Smith 59,698.00 USA Qtrl
lﬂ_SrTli‘th 516,753.00 UK Qtr 3
11 | Smith 518,919.00 USA Qtr 3
12_Wi|liam5 510,644.00 LK Qtr 2
13_Wi||iam5 512,438.00 UK Qtrl
14_Wi||iam5 514,867.00 USA Qtr 3
15_Wi||iam5 519,302.00 UK Qtrd
16

Custom List

In the example below, we would like to sort by Priority (High, Normal, Low). To sort by a custom list
in Excel, execute the following steps.

1. Click any cell inside the data set.

A B C D E F
1 |Last Name Sales Country Quarter Prinri%
2 |Smith 516,753.00 UK Qtr 3 Low i
3 |Johnson 514,808.00 USA Qtrd High
4 |williams  510,644.00 UK Qtr 2 Low
5 |Jones 51,390.00 USA Qtr3 Mormal
6 |Brown 54, 865.00 USA Qtr 4 High
7 |Williams 512,438.00 UK atri Mormal
8 |Johnson 59,339.00 UK Qtr 2 High
9 | Smith 518,919.00 USA Qtr 3 High
10 |Jones 59,213.00 USA Qtr 4 Low
11_Jc|r125 57.433.00 UK Qirl Mormal
12 |Brown 53,255.00 UsA Qtr 2 Mormal
13_'I."‘u"i||iam5 514,867.00 USA Qtr 3 Low
14_ Williams | 519,302.00 UK Qtrd High
15_Sr'r|ith 59,698.00 USA Qirl Mormal
16

2. On the Data tab, in the Sort & Filter group, click Sort.
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The Sort dialog box appears.
3. Select Priority from the 'Sort by' drop-down list.

4. Select Custom List from the 'Order' drop-down list.
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Column Sort On Crder
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The Custom Lists dialog box appears.
5. Type the list entries.
6. Click OK.




Custom Lists

Custom Lists

Custom lists: List entries:

MEW LIST High, Marmal, Lcnw{
sun, Man, Tue, Wed, Thu, Fri,
Sunday, Monday, Tuesday, We Dalata
Jan, Feb, Mar, Apr, May, Jun, I

January, February, March, Apri
London, Paris, Mew York, Berli

I ; rv
(=18
=1

>

Press Enter to separate list entries.

| 814 [}J | Cancel

7. Click OK.
Sort ? it
—|— Add Level < Delete Level E@ Copy Level | Dptions... My data has headers
Column Sort On Cirder
Sort by |Pric|rit1.r | |CEII Values | |High, Marmal, Low |

| oK [}J | Cancel

Result. Records are sorted by Priority (High, Normal, Low).
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Last Name Sales

Johnson

Brown
Johnson

Smith
Williams
lones
Williams
lones
Brown
Smith
Smith
Williams
lones
Williams

$14,808.00 USA
$4,865.00 USA
$9,339.00 UK
$18,919.00 USA
$19,302.00 UK
$1,390.00 USA
$12,438.00 UK
$7,433.00 UK
$3,255.00 USA
$9,698.00 USA
$16,753.00 UK
$10,644.00 UK
$9,213.00 USA
$14,867.00 USA

Country Quarter

Qtrd
Cird
Qtr2
Qtr 3
Qtrd
Qtr 3
atrl
Qirl
Qtr2
Qirl
Qtr3
Qtr 2
Qtrd
Qtr 3

Priori
|High l
High
High
High
High
Mormal
Mormal
Mormal
Mormal
Mormal
Low
Low
Low
Low



Pivot Tables

Pivot tables are one of Excel's most powerful features. A pivot table allows you to extract the
significance from a large, detailed data set.

Our data set consists of 213 records and 6 fields. Order ID, Product, Category, Amount, Date and
Country.

A B C D E F €] H
1 Order ID Product Category Amount Date Country
2 1lCarrots Vegetables 54,270  1/6/2016 United States
3 2 Broccoli Vegetables 58,239 1/7/2016 United Kingdom
4 % Banana Fruit 5617  1/8/2016 United States
5 4 Banana Fruit 58,384 1/10/2016 Canada
& 5 Beans Vegetables 52,626 1/10/2016 Germany
7 & Orange Fruit 53,610 1/11/2016 United States
8 7 Broccoli Vegetables 59,062 1/11/2016 Australia
g & Banana Fruit 56,906 1/16/2016 New Zealand
10 9 Apple  Fruit 52,417 1/16/2016 France
EE ] E 0 R ey e aid o . e B Aafrcfnte mamada

Insert a Pivot Table

To insert a pivot table, execute the following steps.
1. Click any single cell inside the data set.

2. On the Insert tab, in the Tables group, click PivotTable.

[E]==] [F[==] ==
0 07 H
PivotTable Recommended Table
PivotTables

Tables

The following dialog box appears. Excel automatically selects the data for you. The default location for
a new pivot table is New Worksheet.

3. Click OK.



Create PivotTable ? =

Choose the data that you want to analyze
@ Select a table or range
Table/Range: | Sheetl!5451:5F5214 2.5

() Use an external data source

Connection name;
Use this workbook's Data Model
Choose where you want the PivoiTable report to be placed
(®) Mew Waorksheet
() Existing Worksheet

Location: Efez

Choose whether you want to analyze multiple tables

|:| Add this data to the Data Model

Cancel

Drag fields

The PivotTable Fields pane appears. To get the total amount exported of each product, drag the
following fields to the different areas.

1. Product field to the Rows area.
2. Amount field to the Values area.

3. Country field to the Filters area.



PivotTable Fields ~ %

Choose fields to add to report: O -
Search 2
Order ID -
| Product
Category
| Amount
Date
| Country -

Drag fields between areas below:

T Filters Il Columns

Country "

= FRows = Values

Product - Sum of Amou... *
Defer Layout Update

Below you can find the pivot table. Bananas are our main export product. That's how easy pivot tables
can be! :-)

A B C
1 |Country (AN} h
2 |
3 |Row Labels - Sum of Amount
4 Apple 191257
3 |Banana 3402395
6 |Beans 57281
7 |Broccali 142439
8 |Carrots 136945
3 |Mango 57073
10 |Orange 104438
11 /Grand Total 1029734
12
Sort

To get Banana at the top of the list, sort the pivot table.

1. Click any cell inside the Sum of Amount column.



2. Right click and click on Sort, Sort Largest to Smallest.

(@ Copy
Format Cells...
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Iz ValueField Settings...

PivotTable Options...

Hide Field List

Result.
A B C

1 |Country (AN} hd
2

3 |Row Labels -! Sum of Amount
4 |Banana | 340295
5 |Apple 191257
6 |Broccoli 142439
7 |Carrots 136945
& |Qrange 104438
9 |Beans 57281
10 |Mango 57073
11 |Grand Total 1029734
12

Filter

Because we added the Country field to the Filters area, we can filter this pivot table by Country. For
example, which products do we export the most to France?

1. Click the filter drop-down and select France.

Result. Apples are our main export product to France.



A B B

1 |Country France -
2 s
3 Row Labels | -! Sum of Amount
4 |Apple 80193
3 |Banana 38094
6 |Carrots 9104
7 |Mango 7388
8 |Broccoli 5341
9 |Orange 2256
10 |Beans BaE0
11 |Grand Total 141056
12

Note: you can use the standard filter (triangle next to Row Labels) to only show the amounts of specific
products.

Change Summary Calculation
By default, Excel summarizes your data by either summing or counting the items. To change the type
of calculation that you want to use, execute the following steps.

1. Click any cell inside the Sum of Amount column.

2. Right click and click on Value Field Settings.

[@ Copy
Format Cells...

Mumber Format...
|__E.1 Refresh
Sort 3
> Remowve "Sum of Amount'
Summarize Values By L
Show Values s 3
i Value Field Settings...
PivotTable Options... L}

Hide Field List

3. Choose the type of calculation you want to use. For example, click Count.



Value Field Settings ? ot

Source Mame: Amount

Custom Mame: | Count of Amount

Summarize Yalues By  Show Values As

Summarize value field by

Choaose the type of calculation that you want to use to summarize
data from the selected field

Sum A

Average g

Max
Min
Praduct b

MNumber Format Cancel

4. Click OK.

Result. 16 out of the 28 orders to France were 'Apple’ orders.

A B C

1 |Country France -1
2 |

3 Row Labels -! Count of Amount
4 |apple 16
3 |Banana 7
6 |Carrots 1
7 |Mango 1
8 Orange 1
9 |Beans 1
10 |Broccoli 1
11 |Grand Total 28
12

Two-dimensional Pivot Table

If you drag a field to the Rows area and Columns area, you can create a two-dimensional pivot table.
First, insert a pivot table. Next, to get the total amount exported to each country, of each product, drag
the following fields to the different areas.

1. Country field to the Rows area.
2. Product field to the Columns area.
3. Amount field to the Values area.

4. Category field to the Filters area.



PivotTable Fields ~ %

Choose fields to add to report: i
Search o
Order ID -
| Product
| Category
| Amount
Date
| Country -

Drag fields between areas below:

Filters Columns
Category " Product W
Rows = Values
Country " Sum of Amou.. ~
Defer Layout Update

Below you can find the two-dimensional pivot table.

A B C D E F G H | ]

1 |Category (all) -

2

3 |Sum of Amount Column| ~

4 |Row Labels |~ Apple Banana Beans Broccoli Carrots Mango Orange Grand Total
5 |Australia 20834 52721 14433 17353 810 9136 8680 131713
6 |Canada 24887 33775 12407 3767 19929 94745
7 |France 80193 360594 680 5341 9104 7338 2256 141056
& |Germany 9082 39686 29905 37197 21636  B7TS 8887 155168
9 |MNew Zealand 10332 40050 4330 12010 66782
10 |United Kingdom 17534 42908 5100 38436 41815 5600 21744 173137
11 |United States 28615 93061 7Jle3d 26715 S6284 22363 30932 267133
12 |Grand Total 191257 340205 57281 142430 1369045 57070 104438 1029734
13

To easily compare these numbers, create a pivot chart and apply a filter. Maybe this is one step too far
for you at this stage, but it shows you one of the many other powerful pivot table features Excel has to
offer.
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